Wednesday 1st April 2020

Support via Email Connectivity Issues - Support via Email

We are aware of connectivity issues to our Email servers and are currently investigating. No e-mail will be lost as it is currently being queued on an off-site backup relay however it maybe delayed. We can still be contacted via phone (+44 01276 818576) and social media if required. We will provide additional updates as we continue to gather information.

Update 23:35: We have identified the connectivity issues and believe it to be resolved but are continuing to monitor the situation closely

Update 00:05: Connectivity has remained stable, and we're confident this matter has been resolved. If you are still experiencing issues, please contact our support team for assistance.