Sunday 24th May 2020

WordPress Hosting Partial Outage of WordPress Hosting

Our WordPress hosting servers are showing timeouts on some pages and others are slow to respond. We are Investigating.

Update: 18:52 We have identified that a very large number of WordPress sites are being attacked from a very large number of sources. This is very hard to automatically differentiate from legitimate traffic. We are attempting to manually identify a commonality.

Update: 19:12 The attack continues but we are happy that we have mitigated the worst of it. We will continue to monitor and block traffic as required.

Update 20:09 We are continuing to block attacks and monitor the situation however we are happy that sites are up and responding.

Update 21:18 Traffic has returned to normal and all systems are nominal again.