Tuesday 16th May 2017

Support via Email Email server issues

We are currently experiencing issues with our incoming mail server. Customers may find emails to us are delayed.

Update: 15:47 - The ISP that hosts this server had a temporary routing issue. We are watching the issue to ensure the problem doesn't return.

Update: 16:38 - Systems have been running without issue for an hour. Downtime was only 3 minutes. Closing this incident.