Friday 31st May 2019

WordPress Hosting WordPress Hosting Outage

We're currently investigating an issue that is affecting WordPress hosting. This issue appears to be affecting a large number of servers in the same datacentre. We'll update here when we have more.

Update: 13:29 All services are back online and the upstream ISP is investigating

Update: 14:31 We are happy that systems are up and stable.