Friday 31st May 2019

Support via Email Outage of Support via E-mail

We're currently investigating an issue that is affecting our external e-mail. This issue appears to be affecting a large number of servers in the same datacentre. We'll update here when we have more.

Update: 13:29 All services are back online and the upstream ISP is investigating.

Update: 14:31 We are happy that systems are up and stable.