Wednesday 1st April 2020

WordPress Hosting Connectivity Issues - WordPress Hosting

We are aware of connectivity issues to our WordPress hosing servers and are currently investigating. We will provide additional updates as we continue to gather information.

Update 23:35: We have identified the connectivity issues and believe it to be resolved but are continuing to monitor the situation closely

Update 00:05: Connectivity has remained stable, and we're confident this matter has been resolved. If you are still experiencing issues, please contact our support team for assistance.