Dogsbody Technology Status Page

Slow sites on WordPress hosting servers

Resolved
WordPress Hosting
Degraded Performance

At 19:24 we were notified that sites on our WordPress hosting were running slowly.

2022-03-28T18:52:00.000Z
Investigating

We have identified that one of our security partners responsible for checking the security of our customers sites is being a little over zelous and is causing very high load on the infrastructure.

2022-03-28T20:19:00.000Z
Monitoring

We have taken the decision to block traffic from our security partner in order to get sites running at their ultimate speed again. This has returned sites to normal.

2022-03-28T20:49:00.000Z
Resolved

All systems are back to normal now, but we're monitoring closely. In this case our own protection bit us. Our partner was not rate limited like normal traffic was and so managed to case this issue. We will be changing this setup during our next maintenance window.