Dogsbody Technology Status Page

Support Phonelines unavaliable

Resolved
Support via Phone
Degraded Performance

We have identified an issue with our external phone number becoming unavaliable.

2021-11-22T10:35:00.000Z
Resolved

We have identified the issue (it was DNS) which has now been resolved. All calls in and out are working again fully.